Jump to content
  • 0

Klipper config for Orbiter 2.0 Problems


noghost23

Question

My Voron 2.4 running Klipper had been running great for a while but the afterburner assembly was starting to show weakness. I thought it was a good time for an upgrade so I installed a new Orbiter 2.0 with filament detector on my Voron 2.4 and the problems began......

witht he Orbiter 2.0 installed i have not been able to get my rotation distance anything like close to accurate. last print had massive over extrusion with lots of noise from the extruder.

To statrt isolating the problem /as an experiment I ran 50mm (requested) filament through the extruder body only (no lower nozzle assempbly) and got about 250mm of filament instead.

Fortunately the awful noise stopped. Ergo i think my initial problem is that the over extrusion i jsut discovered was overwhelming the nozzle and jamming.

easy so far. On to the print config.....

And incredible frustration as any and all changes to the print config file make no measurable difference in the amount of over feed. here is the code after a lot of trial and error and no change (i suspect there are a number of settings that i have turned off or on to see what if anything would happen- no change.). here is the code-

 

#####################################################################
#   Extruder
#####################################################################

##  Connected to MOTOR_6
##  Heater - HE0
##  Thermistor - T0

[extruder]
step_pin: PE2
dir_pin: PE3
enable_pin: !PD4
##  Update value below when you perform extruder calibration
##  If you ask for 100mm of filament, but in reality it is 98mm:
##  rotation_distance = <previous_rotation_distance> * <actual_extrude_distance> / 100
##  22.6789511 is a good starting point #Bondtech 5mm Drive Gears AfterBurner
##  34.37086 for Bondtech 8mm gears (Galileo
##  rotation_distance: 4.637 for Orbiter 2.0
rotation_distance: 4.637
##  Update Gear Ratio depending on your Extruder Type
##  Use 50:17 for Afterburner/Clockwork (BMG Gear Ratio)
##  Use 80:20 for M4, M3.1

# orbiter motor LDO-36STH20-1004AHG(XH)
# gear_ratio: 7:1               
microsteps: 16
full_steps_per_rotation: 200    #200 for 1.8 degree, 400 for 0.9 degree
# max_extrude_only_distance: 500
# max_extrude_only_velocity: 120 # <- for orbiter motor LDO-36STH20-1004AHG(XH)
# max_extrude_only_accel:    800 # <- for orbiter motor LDO-36STH20-1004AHG(XH)

nozzle_diameter: 0.400
filament_diameter: 1.75
heater_pin: PA2
##  Validate the following thermistor type to make sure it is correct
##  See https://www.klipper3d.org/Config_Reference.html#common-thermistors for additional options
sensor_type: SliceEngineering 450
sensor_pin: PF4
min_temp: 10
max_temp: 270
max_power: 1.0
min_extrude_temp: 170
# control = pid
# pid_kp = 26.213
# pid_ki = 1.304
# pid_kd = 131.721
##  Try to keep pressure_advance below 1.0
pressure_advance: 0.025
##  Default is 0.040, leave stock
pressure_advance_smooth_time: 0.030

##  E0 on MOTOR6
##  Make sure to update below for your relevant driver (2208 or 2209)

[tmc2209 extruder]
uart_pin: PE1
interpolate: False
run_current: 0.85 
hold_current: 0.100
sense_resistor: 0.11 
stealthchop_threshold: 0
# driver_TBL: 0
# driver_HEND: 6
# driver_HSTRT: 7
# driver_TOFF: 4

 

######################################################################################################

## I haven't made any changes above or below these lines so i the problem MAY be in here##################################

######################################################################################################

 

All of which leads me to my theory - incorrect wiring of the ldo-36st17-1004ahg to the tcm2209. Now i am very new to electronics and the instructions for wiring the Orbiter 2.0 to the V2.4 are yet to be found by me (if anybody has them, please share) so it would be an easy mistake.

 

i feel like this is some sort of reversed polarity issue and leaves me with no idea where to begin with figuring this out.

 

anybody got any ideas?

 

 

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

What control board are you using?

With my Octopus, using the same motor and extruder, I think I had to swap the Yellow (B2) and Blue (B1).

Also I noticed that you had the SpreadCycle parameters commented out. Frankly I haven't tried without them and I'm not certain of the difference but I took the config from the manual so I'd stick with it. Also interpolate is set to 'true' in the default config  yours is false.

That's my tmc2209 config in Klipper:

[tmc2209 extruder]
uart_pin: PE1
interpolate: true
run_current: 0.85
hold_current: 0.100
sense_resistor: 0.11 #
stealthchop_threshold: 0
driver_TBL: 0
driver_HEND: 6
driver_HSTRT: 7
driver_TOFF: 4

Edited by raddvaan
  • Like 1
Link to comment
Share on other sites

  • 0

This is based off the recommend config from the Orbiter Project, with updates to match the current Klipper recommendations.

[extruder]
microsteps: 16 # the klipper recommendations is 32 but with a high gear ratio box like
			   # the Orbiter I think the extra resolution is not needed
full_steps_per_rotation: 200
rotation_distance: 4.637
nozzle_diameter: 0.4                   #define nozzle diameter
filament_diameter: 1.750
max_extrude_only_distance: 500
max_extrude_only_velocity: 120
pressure_advance: 0.025                #to be calibrated
pressure_advance_smooth_time: 0.03     #to be calibrated

[tmc2208 extruder]
interpolate: False # Current Klipper standard is to disabled this
run_current: 0.85 # Set to your motor current
#hold_current: 0.100 # Should not be set
sense_resistor: 0.11 # Set to your Stepstick value
stealthchop_threshold: 0
#driver_TBL: 0 # I'm not sure why these are in the default from the orbiter project but I have them commented out.
#driver_HEND: 6
#driver_HSTRT: 7
#driver_TOFF: 4

I hope this helps.

Link to comment
Share on other sites

  • 0

Hey @Methos

My Extruder settings are below:

[extruder]
step_pin: PE2
dir_pin: PE3
enable_pin: !PD4
##	Update value below when you perform extruder calibration
##	If you ask for 100mm of filament, but in reality it is 98mm:
##	rotation_distance = <previous_rotation_distance> * <actual_extrude_distance> / 100
##  22.6789511 is a good starting point
rotation_distance: 4.637 	
##	Update Gear Ratio depending on your Extruder Type
##	Use 50:17 for Afterburner/Clockwork (BMG Gear Ratio)
##	Use 80:20 for M4, M3.1
gear_ratio: 7.5:1 				#BMG Gear Ratio 50:17
microsteps: 16
full_steps_per_rotation: 200	#200 for 1.8 degree, 400 for 0.9 degree
nozzle_diameter: 0.400
filament_diameter: 1.750
heater_pin: PA2
##	Validate the following thermistor type to make sure it is correct
sensor_type: ATC Semitec 104GT-2
sensor_pin: PF4
min_temp: 10
max_temp: 270
max_power: 1.0
min_extrude_temp: 170
max_extrude_only_distance: 500
max_extrude_only_velocity: 120
#control = pid
#pid_kp = 26.213
#pid_ki = 1.304
#pid_kd = 131.721
##	Try to keep pressure_advance below 1.0
pressure_advance: 0.025
##	Default is 0.040, leave stock
pressure_advance_smooth_time: 0.03

##	E0 on MOTOR6
##	Make sure to update below for your relevant driver (2208 or 2209)

[tmc2209 extruder]
uart_pin: PE1
interpolate: false
run_current: 0.85 #**
#hold_current: 0.100
sense_resistor: 0.11 #**
stealthchop_threshold: 0
#driver_TBL: 0
#driver_HEND: 6
#driver_HSTRT: 7
#driver_TOFF: 4

 

It's strange as I'm getting the same huge amount of over extrusion as @noghost23  - I would say by a factor of 10 - the rate at which the filament extrudes is so fast - at first I thought I had my gear ratio's wrong but they are 7.5:1 and the rotation distance is 4.637 as recommended.

Maybe this is a wiring issue but the pairs on the stepper seem to match the pairs on the octopus msu (I'm still old school - cablechains back to the MCU).

 

 

Edited by StalkS
Link to comment
Share on other sites

  • 0
On 9/29/2022 at 1:13 PM, raddvaan said:

What control board are you using?

With my Octopus, using the same motor and extruder, I think I had to swap the Yellow (B2) and Blue (B1).

 

@raddvaan  If you have a moment could you let me know which went where as I am not sure if statement above is before or after you did the swap - sorry for being pedantic but I have almost run out of micro molex pins and only have enough for one more change so I want to be certain 😄

 

My Setup:

Octopus            |   A1   |     A2    |    B2    |    B1    |   

LDO Motor        |  Red |  Green  | Yellow |  Blue  |

 

Hoping you see this! Thanks!

 

Edited by StalkS
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...