Jump to content
  • 0

1st build - Step motor testing



Hello Everyone!

I'm building my first Voron 2.4 r2 LDO 350 kit with an Octopus 1.1 board, mainsail OS.  I am getting hit with this error:

I've followed the LDO wiring docs for this board found here:https://docs.ldomotors.com/en/voron/voron2/wiring_guide_rev_a

It seems like the motors are not getting power. Pretty sure that im doing something silly,  just not experienced enough to know what yet.

for what its worth, the bed heater and rapido hf hotend DID heat up (yay, small win).  

(screenshot of documentation, but my board is wired the exact same way, just not a clean.)


Does anyone have any thoughts?  Happy to provide more info if needed!


Sincere thanks in advance!




Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 1
1 hour ago, shiftynick said:

Does anyone have any thoughts? 

I cannot see a GND going to the motor power on the octopus board. Looking at the photo provided, the far right terminal is empty(GND), then there is a positive which is motor power positive, next set is power in GND and,positive , then Bed Power GND and positive,  then Bed Out Pos,GND. 

You have all wired up correctly but no GND to Motor Power and no GND to Bed Power.



Link to comment
Share on other sites

  • 1

Couple of other thoughts:

Make sure the jumpers on the Octopus board is set to UART mode:


Motor 2 has two motors running of the same stepper driver (motor2_1 and motor2_2). It sends the same signal to both motor, thus cannot be individually controlled)

Unplug the z-stepper motor from Motor2_2 and plug it into motor 2_1 (next to X and Y steppers). Maybe that socket needs to be active before the second will activate - just a guess)  Leave the rest as they are.

Ensure the driver for stepper Z (motor 2) is properly seated in it's socket.

If that does not work:

Exchange the last stepper driver driver(motor6)  with the third stepper driver (motor 2) and see if that makes a difference (See if it is a faulty stepper driver)

In the printer.cfg file z-stepper will be motor 2, Z1 motor 3 and z2 motor 4 with the extruder motor5. AB drives (X,Y) will be motor 0 and motor 1)

  • Thanks 1
Link to comment
Share on other sites

  • 0

Thank you!  I ran some jumpers to the Octopus power NEGATIVE terminal. I am encountering the same error however.  



Could this be something in the printer.cfg or most likely caused by a wiring issue? I attached my klippy logs in case it was beneficial.  I used the LDO config file here:

https://github.com/MotorDynamicsLab/LDOVoron2/blob/main/Firmware/octopus-printer.cfg but adjusted for my build to the best of my abilities.

Thanks again in advance.  

klippy (1).log

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...