Jump to content

Stealthburner LEDs won’t turn off


Mcrcheli
 Share

Recommended Posts

I have the neopixle leds in the stealthburner set up to turn on upon machine power on. That works fine. I can change initial color the only within the print.cfg. I can not get the led to turn off. The standard button in Mainsail sends the gcode but the light remains on. I could not get the led to work on my octopus1.1 on the LED header with pin PB0 at all . 5V was present but no response. I moved over to PB7 and now it’s I said it will turn on but not turn off. I am thinking the LED header pin PB0 may not be working. I am using the toolhead one piece PCB so I thought maybe a problem with the signal going through the board. I did a direct connection on PB0 with the same result and direct to PB7 with the on only result. 

  [neopixel sb_leds]
  pin: PB7
  chain_count: 3
  color_order: GRBW
  initial_RED: 0.0
  initial_GREEN: 0.0
  initial_BLUE: 0.0
  initial_WHITE: 1.0

 

Link to comment
Share on other sites

30 minutes ago, Mcrcheli said:

color_order: GRBW

Try and manually turn them of in the console (command line) by issuing the following command:

SET_LED LED=sb_leds GREEN=0 RED=0 BLUE=0 WHITE=0

If this turns them off, then there may be an issue with the macro (maybe WHITE=0 is not included in the macro)

As they turn on, it may suggest that the pin is actually working and it is getting enough Voltage to the pin.

 

Link to comment
Share on other sites

45 minutes ago, Mcrcheli said:

I tried that and that did not work. I can set it to an initial of 0 and it is off. Can not turn it on from that point.
Thanks

Mmmmh

Only other thing I can think of is to check that you are getting 5v and not 3.3V

Perhaps try changing RGBW to just RGB and see if that helps. Will have to do some research on this

Link to comment
Share on other sites

Yes, 5Volts. I tried power from multiple areas even just the 5v supply. I tried every. O Bo, RGB, rGBW, GRBW

same result. You can see why I thinking the RGB header is not working.

Thanks for your help. I may have to get another board once I get everything else settled.

Link to comment
Share on other sites

Just a thought, do you have a 100ohm Resistor in the toolhead and I think another at the MCU end for the neo pixel data line?

Been a while and I can't find my notes and haven't seen latest SB manual since BETA was over, but I recall issues with color changing and not turning on / off when there's too much noise on the data line. The resistor cleans this up a little. 

Link to comment
Share on other sites

Found some old notes.

As mentioned, this might not help you, but temporary connections and a simple few tests should be able to rule it in or out.

One of the Voron users did an analysis with an Oscilloscope and saw that there was a lot of noise on their NeoPixels (during SB beta) and adding the resistors "cleaned" the data signal up.

FYI - I have an Octopus 1.1 board and using the RGB port. Not using logic level shifters or anything.

  • I have a 100 Ohm resistor inline on the PB0 (Data) line, close to where the connector plugs into the MCU (Octopus).
  • I have another 430 Ohm (can be in the range of 400-480) inline on the data line inside the SB body.

These are soldered and shrink wrapped to ensure strong connection and no shorting.

This seems to vary and affect different scenarios - so take it on a case by case basis as it doesn't seem to be a common thing anymore but I don't know why as my main printer needs them both and has worked flawlessly since adding them. Maybe it's the batch / model of LEDs / wiring interference or something.

Hope it helps you mate!

Link to comment
Share on other sites

I tried with both resistors and a few different values around 400. The only difference was the color of the LED changed to red even though it had white value of 1. This was on PB7 and still LED will not go on at PB0 even with the resistors. I have a new board coming in a few days. I think it’s the board. I could not get the inductive probe to work, so I went to the Euclid probe (great little probe). I have parts for the TAP probe on order and should get that working next week. Anyway, Thanks for all your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...