Jump to content
  • 0

Need help configuring KAMP


mbunjes

Question

Hi, I installed KAMP and all went well, no errors. However it doesn't work  I'm a bit at a loss what exactly to put in my PRINT_START macro .
I read somewhere that the only thing you need is bed_mesh_calibrate but that's exactly what it does : it calibrates the whole bed.

I would like to know what exactly to put in my printer.cfg. 
I have include KAMP_Settings.cfg and eclude_object

I uncommented the features I want in kamp_settings_cfg

What else do I need ?

Link to comment
Share on other sites

22 answers to this question

Recommended Posts

  • 0

Did you turn on the label objects option in your slicer?

In my print_start I just have calls to BED_MESH_CLEAR, then BED_MESH_CALIBRATE. Later I call the SMART_PARK to position the nozzle while doing final heating and finally LINE_PURGE (for whatever reason VORON_PURGE stopped sticking much and goobered up my first layer as often as not).

Link to comment
Share on other sites

  • 0

I had to follow the 'manual'.

First get the 'exclude objects' to work (add [exclude_object] somewhere below the include lines in printer.cfg.

Then add [include KAMP_Settings.cfg].

Open the file KAMP_Settings.cfg and customise if necessary.

All you need to do to activate the script, is to call BED_MESH_CALIBRATE in your print_start macro.

This is overridden in their code, to recalibrate according to the objects you want to print.

Ah... I also had to add M117 somewhere before the start GCODE. I believe it is sometimes necessary to 'wake up' klipper? so it starts the exclude_object recognition.

Mine is right there in superslicer in custom_g_code under printer settings. Until I added M117 there, exclude objects wouldnt work for me

_________________

M117 
print_start EXTRUDER={first_layer_temperature[initial_extruder] + extruder_temperature_offset[initial_extruder]} BED=[first_layer_bed_temperature] CHAMBER=[chamber_temperature]

_________________

hope it helps 🙂

 

Link to comment
Share on other sites

  • 0

Unfortunately, it's not working. It's just doing a regular bed mesh.

In the Fluidd console I saw the line "No objects detected! Check your gcode and make sure that EXCLUDE_OBJECT_DEFINE is happening before BED_MESH_CALIBRATE is called. Defaulting to regular meshing.

I do not have EXCLUDE_OBJECT_DEFINE in my printer.cfg, only EXCLUDE_OBJECT. What does it mean ?

And it's here right at the beginning of my printer.cfg and BED_MESH_CALIBRATE is somewhere in my print_start macro 

Link to comment
Share on other sites

  • 0

KAMP works apparently by using the exclude_objects system from Klipper... It is explained in their documentation.

I wrote also in my previous post: add [exclude_object] in printer.cfg

mine looks like this:

 

-----------------------

[include mainsail.cfg]

[include stealthburner_leds.cfg]
[include NozzleScrub.cfg]
[include lcd_tweaks.cfg]
[include KAMP_Settings.cfg]

#enable object exclusion
[exclude_object]
----------------------

make sure you enable labeling in superslicer.

And done.

Oh, do not leave out the m117 🙂 

Good luck

 

 

Link to comment
Share on other sites

  • 0

Hmm.... the error message you get (defaulting to regular meshing) suggests object exclusion did not work.

When I did it, I had the same until I added m117 and a restart of the printer.

I just checekd the KAMP github again.. 

- [exclude_object] in printer.cfg - you have

- SSlicer object labeling is enabled.

- did you also add the section:

 

[file_manager]
enable_object_processing: True
in moonraker.conf?
 

 

 

If you did all this and object exclusion is still not working, then I am out of ideas (except looking online to similar cases).
 
 

 

Link to comment
Share on other sites

  • 0

Egg on face 😉 That was the solution. It's working flawlessly now.

One question : In Fluidd's gcode proview there's a difference: there's a blue line around the model and a blue spot in the middle that when clicked asks whether I would like to exclude this object.
 

What's the meaning of this ?

Screenshot - 15-Dec-23 , 16_41_43.jpg

  • Haha 2
Link to comment
Share on other sites

  • 0

Yeah... The first thing a helpdesk worker tells you to do: did you plug the cable in, second is: did you restart the computer?

I do not use fluid. I assume it is similar to mainsail. Slice multiple objects, more than a few and then see what happens. I guess you need the experiment. The whole idea of object exclusion is, to 'stop printing spaghetti'. So when there is a failed object (during the print you see it warping or losening from the plate) , and the rest is printing well, you have the chance to stop this object only from printing.

This is the API KAMP uses to have a small part of the bed meshed.

Line purge did not work for me either. I use the voronpurge. much cooler. You have to play with the settings. For me initially it was too thick and too close to the printing area: the stealthburner would hit the purge during printing of the skirt.

So... I would say, experiment a bit 🙂

Good luck

Link to comment
Share on other sites

  • 0
23 hours ago, mbunjes said:

Egg on face 😉 That was the solution. It's working flawlessly now.

One question : In Fluidd's gcode proview there's a difference: there's a blue line around the model and a blue spot in the middle that when clicked asks whether I would like to exclude this object.
 

What's the meaning of this ?

Screenshot - 15-Dec-23 , 16_41_43.jpg

"Reboot fix everything!" 😄

That blue outline shows the defined object. The slashed circe in the middle is where you click to exclude the object. It's such a valuable addition to Klipper; I've lost count of the plates saved from failure due to one or two small parts.

For the line purge, did you uncomment the include for line_purge.cfg? Line and Voron purge are different files.

  • Like 1
Link to comment
Share on other sites

  • 0
14 hours ago, PFarm said:

Did you remove the space between the number sign and text, the text needs to turn green.

yes, I did.

I get the following message in my console :

max_extrude_cross_section is insufficient for purge, please set it to 5 or greater. Purge skipped.

It would be great if they would tell where to set that, as it is it just baffles me ?

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...