Jump to content
  • 1

Please someone share my Z-endstop switch woes!


DennisM
 Share

Question

 

TL;DR: I hate this part of my build! I cannot get a working Z-stop that's reliable and it's frustrating as heck.

 

[rant]

I can't believe that the most difficult part of my 2.4r2 build is the stupid z-endstop! Some time ago I came across the sex bolt mod and though, that's a good idea, the pin can't fall out, right? So I bought that and printed the piece. Unfortunately, for some reason the pieces just didn't fit properly and I ended up ruining both the brass cylinder pieces and my PCB switch. So I bought another PCB switch and a pack of the brass cylinders from Amazon and tried printing the piece again. This time I scaled it to 101% trying to make things fit better. I should note that I have not had any other fit problems with the rest of my parts, so I don't want to blame my printer.

So this new piece seemed to work a bit better, but things kept sticking (press down and it wouldn't come back up), so I tried numerous things. I've gotten good at removing the stop from the bed now. In the middle of everything, I had an issue with the cable connector so I redid that and we were back in business as far as the connector & wiring.

I couldn't figure out what was sticking. I eventually thought it was the screw head inside the unit, so I shaved some plastic off the hole in the bottom to make more room. This seemed to help. So I put everything back together, and more than once (many times) everything seemed OK but once I installed the unit after a few minutes something would "settle" or whatever and the pin would stick again. I tried adding grease to the sexbolt but that didn't fix things. The common factor in this whole mess is the sexbolt itself, which I wonder if it's bent or something, not sure. I don't have another spare and I'm not buying another kit.

Eventually it seemed like I was good, things were working and I moved on to other stuff like the Z calibration, etc. thinking I was good.

During one of my first prints, however, I noticed the head moving past the Z stop and the euclid probe on the head getting too close for comfort. The magnets actually clicked on the Z stop, and it was just too close for my taste. So I thought, well, remove the Z stop and tighten the bolt some more to lower the sexbolt head. I measured what I was using and it was 2.5mm above the bed. I think that was too high.

Took everything apart, changed the M4 bolt to an 8mm (I had switched to a 12mm because it was too low before), added Loctite and then just kept turning, assembling, and measuring where I was with the bed height. Finally I thought I was good, so I finished it up and ran a Z home. The stop head was basically level to the bed, and that didn't work, it gave me an error because I think the bottom of the toolhead contacted the bed although I wasn't sure.

So I figured I needed to raise it a little, and that one thought turned into another hour of adjusting, installing, sticking, drilling out some more plastic inside, greasing, adjusting, sticking, etc. It was another frustrating time with the thing. Finally I thought I had things working after clearing out yet more plastic inside the unit, so I put it all back together and ran homing operating.

The head dropped down to the Z stop and when it moved back up the stop didn't close (got stuck again).

So I decided to stop, walk away, and come here to rant about it.

I should state that I tried the original probe many times but the rod was too long, and I wasn't ready to figure out how to cleanly cut it. Plus I thought, well it could fall out but how many of us turn our printers almost upside down? I may end up going with this route, but I'm not sure. Also, I went ahead and ordered the last "completely assembled" sexbolt z-stop assembly that Fabreeko had in an effort to make this problem go away.

[/rant]

 

If you made it this far, thanks for reading and maybe feeling my pain 🙂

 

Dennis

  • Sad 1
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

If I may suggest, even though sunken cost fallacy hurts, have you considered going for the 'clicky probe' instead of the classic Z-stop?  https://github.com/jlas1/Klicky-Probe

It's very liked by the community and considered by many to be a 'must'

 

Also, I don't like the stock z-stop I'm using either. I'm going clicky eventually but for now I adjust my Z-height manually at every bootup.

Link to comment
Share on other sites

  • 0

I'm using the euclid probe with excellent results. I just didn't want to have to wait for the deploy, measure, stow process each time I needed to home Z.

In an effort to sort this out, I modified one of the models and opened up the stuff on the inside a bit to make room for what I guess are larger screw heads. I also made some additional room for the switch so I can't destroy it taking the thing apart to adjust.

This new model has been assembled but I still have the sticky presses once in a while, so I'm going to assume it's the sexbolt part. The part recommended by the github site is an Amazon bolt that has a philips head, which won't work because the nozzle could measure inside the plus opening and get a different measurement.

I'm going to look around for something similar with a flat head.

Link to comment
Share on other sites

  • 0

OK, so I have to give up or I'm going to destroy something. Already threw it all away since it was not working. I did keep the PCB since that's still good 🙂

I found a set of Chicago bolts that I already had and had one that was 5x18mm which was close enough, but it still was "sticky" and unreliable.

I'm going to call it a day with the printer work for now and calm down and wait for the Fabreeko shipment arriving tomorrow with the fully assembled sexbolt z stop in there.

I can't believe how frustrating such a simple thing is! If the new one is also sticky or otherwise has issues, I'm designing my own version and be done with it. I'll see how it goes. Crossing my fingers that the one I get tomorrow works out better than what I've had bad luck with.

  • Like 1
Link to comment
Share on other sites

  • 0

I feel your pain. My Sexbolt install was a bit fraught as well, seemingly in the same ways. I did have to do some post-processing work shaving bits on the inside to get clearance I am happy with where all the parts bolt together without issues. I also ran into the sticky bolt problem; what I ultimately did was put a tiny (as in TINY) dab of the PTFE lube for the linear rails on the bolt--it's been working smoothly and stick-free ever since.

I have the top of the bolt set to *just* above the print surface. I run Klicky probe, and have my print_start macro set to mount the probe early in the process and leave it on until all calibration is done. So it does a single mount move at the beginning and a single dock move at the end. There is clearance with carefully choreographed moves for the nozzle scrub on the brush.

Also, since I'm using Klicky, I installed the auto-z macros & library, so the printer recalculates Z offset at the start of every print (along with an adaptive mesh). I get a hands-off perfect first layer every time.

Worst case I've run across after getting it all set up is printing from cold in the morning (first print), the measurements sometimes are a bit wonky. Usually I just get an error of offset out of range. Once or twice it was a bit high. Cancelled print & restarted firmware, then it all went back to normal of fire-and-forget.

Link to comment
Share on other sites

  • 0

After a few more frustrating attempts I believe I have found the root cause of all my issues, and I hope this might help someone out there.

I received the "fully assembled" unit from Fabreeko but it had some minor issues which I took care of. It seemed to be in excellent working order, and it worked for a while even after installing it. I thought my problem was solved until I was showing the printer to a friend and when doing the QGL it stopped with a failure of the z-stop being engaged. Sure enough, pressing down on it did nothing, it was stuck again.

The next day I worked on it some more, and after taking it off the printer I noticed it was sticking again, so I replaced the brass cylinder pieces again and it seemed to be OK. I tested it in my hand many times and no matter how fast I clicked it, or turned the bolt, it worked like a charm. To get it to this point I needed to run a quick drill bit through the brass to *slightly* enlarge it, or remove burrs, not sure. But it worked great. Then I installed it and it began sticking again.

After removing it, I realized what was happening. When tightening the M3 bolts holding it into the 2020 frame, somehow it deforms the brass cylinders. I removed it again, and replace the brass again, then this time instead of using the M3x16 (I think that's the size) I used longer M3x25 or 30, I forgot, but attached washers to the outside so that the head would not protrude into the Z-stop housing. Instead the washers pressed up on the outside of the housing. I was still able to get it tight enough that it's not going anywhere, and the plunger seems to work flawlessly.

So I believe the root cause is the deforming of the brass cylinders when tightening the bolts to hold it into the extrusion. I wasn't hulking them down or anything, just tightening enough to keep it in place, but it still deformed it enough to bend the brass cylinders out of round.

So if this is my last post here, assume that this was the problem and the solution! I'll update otherwise.

Thanks for reading!

  • Like 3
Link to comment
Share on other sites

  • 0

I'm back 😞

I didn't end up using the Fabreeko assembled unit; instead I created a hybrid endstop and I'll see how it works out. Here's what I did:

  • Created a variant of the hartk1213 endstop with more space inside the unit under the sexbolt to allow room for an M4 washer
  • Added a spring to the plunger to require a harder press. This was suggested by protoloft's auto Z calibration to compress any filament dripping off the nozzle.
  • Added an M4 washer to the M4x16 bolt inside the unit to prevent the plunger from freely popping up from the Euclid magnets on the toolhead if the toolhead passed over while printing a skirt close to the edge.
  • Fastened the unit to the 2020 extrusion using M3 bolts with washers that didn't stop inside the unit to prevent the original deformation problem I outlined earlier. I didn't have the right size SHCS bolts so I used FHCS M3x25 with 2-3 washers each to get the right length.

So far this new version is working out for me. I did have to run a drill bit inside the brass cylinder briefly to make the plunger slide freely inside the cylinder. The total travel of the plunger is very small -- basically just the travel of the switch action only. And the hard press with the spring does compress any oozing filament on the nozzle.z-stop-opened-up.stl

Anyway, it seems like others don't have the problems I have, but this solution seems like it's going to work out for me.

IMG_6623.JPG

IMG_6624.JPG

IMG_6625.JPG

IMG_6628.jpg

Edited by DennisM
Link to comment
Share on other sites

  • 0

Go with UnKlicky sexbolt.

I had some strange problem with Zhoming not consistance with my sexbolt also (maybe the microswitch).

I decided to go toward Unklicky sexbolt here:

https://github.com/majarspeed/Unklicky/tree/main/Unklicky_Endstops/Unklicky_SexBolt

There is not a lot of friction and the magnet is doing the job to move back the bolt. I can not be more happy !!!

Try that!! I'm pretty sure that will fixe your problem! I did the version with the shoulder bearing.

 

Edited by rickdnamps
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...