Jump to content
  • 0

First initiation (STEP motor testing)


Ilan_Maimon
 Share

Question

Hi everyone, this is my first time building a Voron 2.4r 3D printer. 

I completed the build, configured the Printer file. and successfully connected with the printer through the local network dashboard.

I start testing all the wiring connections, and I successfully heated up the bed and the extruder. till this point all is working as expected. 

Now,  when I'm trying to BUZZ the STEP motors (any of the printer's step motor) i get the following  message:

 

Unable to read tmc uart 'stepper_x' register IFCNT
Once the underlying issue is corrected, use the
"FIRMWARE_RESTART" command to reset the firmware, reload the
config, and restart the host software.
Printer is shutdown

and i need to restart the printer.

this error is popping up regardless the step motor i try to BUZZ...

can anyone suggest where should I start looking for the solution? 

thanks

 ILAN 

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Hi ILAN

It would be helpful to know which controller board you are using (e.g. Octopus 1.2, SKR 1.3, etc) and get a copy of your printer.cfg. The message (as I understand it) means that klipper cannot interface/control/access/read the TMC driver chip that will be connected to the motor.The fact you say it is all  the motors that (to me) indicates a misconfiguration either of jumpers on the board or (more likely) within the printer.cfg file, rather than some awful hardware failure (dead TMC driver).

NB: I'm making a big assumption you're using Klipper here 😀

A good starting point for checking the config is the Voron 2.4 Github repository (https://github.com/VoronDesign/Voron-2/tree/Voron2.4/firmware/klipper_configurations) or if you're using some other MCU board or are just wanting to double check there is also the stock klipper configs at  https://github.com/Klipper3d/klipper/tree/master/config .

The best approach is to focus on getting just one motor working (i.e. making a limited number of chances in a single definition).

I am sure the other guys who have built 2.4s will have [better] advice as well.

 

Link to comment
Share on other sites

  • 0

Dear Supporter, thanks for your quick respond.

i am using the BigTreeTeck controller Octopus 1.2. 

Mainsail OS 

on the "machine" dashboard all software are updated, no errors, and communication is running smoothly until i try to move any motor (end stops, heaters and temperature readings are all working well) 

 

Drivers' jumpers were set for UART communication. (not SPI) - is that correct? (I assume other jumpers are less important for this matter.) 

now i am working on the config file you linked above, to compare possible problems. it seems that this is the same file i had been using to configure my build.     

it is definitely on all the motors/channels same exact error.  

moreover when this problem occurs the extruder fans will start running till firmware restart. (maybe this detail help you considering)

 

thanks

ILAN MAIMON    

 

Link to comment
Share on other sites

  • 0

 

15:41:15
Klipper state: Ready
15:41:08
Klipper state: Disconnect
15:41:08
15:40:59
Klipper state: Shutdown
15:40:59
- Type HELP to get a list of available commands.
- Click on the "?" button to get a searchable list.
- Commands in the console are clickable and will be placed into the input field.
- Use the tab key to complete your inputs. If there are several options, a list is displayed.
- Use the ⇵ arrow keys to navigate through the previous entries.

 

 

 

Link to comment
Share on other sites

  • 0
3 hours ago, Ilan_Maimon said:

Drivers' jumpers were set for UART communication. (not SPI) - is that correct?

UART is the correct setting, think that's just a single jumper underneath the TMC drivers that's needed to set UART mode

 

3 hours ago, Ilan_Maimon said:

moreover when this problem occurs the extruder fans will start running till firmware restart

That's a safety feature (I think) when the controller board "panics" (stops all of a sudden) it'll run the fans at full speed to make sure that nothing accidentally melts, say, if the hotend was still active.

 

The fact that it is every single driver/motor does point to a configuration issue (wihch has been applied consistently across all the drivers) as opposed to being super-unlucky and having multiple faulty TMC drivers.

Link to comment
Share on other sites

  • 0

thanks for the support and second opinion. my logic is similar to yours.

Therefore, I have applied to the kit's supplier (at ALiEx) for support and resolution.

One thing he shared immediately is that the STEP motors i am using are 9degree per step (the parameter to set is 400 instead of 200) however, even after correcting this parameter the problems stayed same. 

i have sent him my configuration file, and hope to get him sort the problem out soon... 

i'll update her accordingly. 

thanks  again.

ILAN MAIMON

Link to comment
Share on other sites

  • 0

The differences between 0.9 and 1.8 degree motors wouldn't cause the issue. The worse that would happen was too much movement as the steps were wrong. Unless the motor wiring is wrong, but I would expected that to exhibit as buzzing rather than the horrible failure you are getting.

Let us all know how you get on. Good luck!

Link to comment
Share on other sites

  • 0

What are your TMC2209 settings in the motor sections looking like.

Could you post your [stepper_x] and [tmc2209 stepper_x] sections of the printer.cfg file as an example to help troubleshoot?

Also your first stepper driver seems "off skew". Have you tried removing the stepper drivers from the board and re-installing them. Make sure the pins aren't bent and seat in the slots - this may help with trouble shooting

  • Like 1
Link to comment
Share on other sites

  • 0

thanks for all the support,

the problem was resolved, and as always it is simple and basic mistake...

i found that I misunderstood the power connection scheme (the 24V DC power input) to the BTT Octopus. I didn't connect the bridge wires to the main power supply wires therefore motors could not get the 24V required to start...

now all is working.

thanks again for your support.

ILAN MAIMON. .   

  • Voron FTW! 1
Link to comment
Share on other sites

  • 0

Sorry to bother you again.

..... after progressing forward, now it seems that i can not satisfy the probe to complete a quad gantry leveling. (QGL) 

after homing the printer and when starting the QGL, after one round of measurements i get:  

Probe triggered prior to movement

and the process is stopping.

 

any idea? 

 

Link to comment
Share on other sites

  • 0

Not at all, we're all here to help one another.

Although, I will definitely defer to my learned colleagues, like @mvdveer, who have 2.4's. Knowing what sort of probe you have would be useful (I'm presuming it is a inductive PL-08N type probe, the square one). Personally, any time I have had problems with (inductive) probes it's either been sensitivity, wiring or voltage.  I have seen discussion of "probing speed" being a cause of premature triggering but personally I've never run my probing so fast as that to be an issue.

Iinductive probes really work best over iron but in the 3D Printing world (for good reasons) all our beds are aluminium which is not the best for inductive probes. This sensitivity issue presents as variable detection accuracy at differing points over the print surface. That probably doesn't help you other than explain why I use things like BLTOUCH or (eventually)klicky. Sorry. There's a small chance your probe could be mounted too close to the bed and is triggering too early? (small chance)

The inductive probes often require "high" voltages to operate (think in the 12v - 36v range). I don't have an Octopus board to hand so can't tell if it will have a probe connection that supplies (24v) or just (5v). It probably does as it has a zillion connections but it's worth checking that.

However, the biggest cause of issues I've personally seen are loose/intermittent connections. Which can be a pain to track down (try and deliberately move a wire to cause a fail and it works perfectly.....accidentally breath on it and it all stops working).

You could try a PROBE_ACCURACY command in the klipper/mainsail terminal/console window. That'll make the  machine probe 10 times in a row. See if it works all the way through and gives reasonably consistent results.

However, as I say, I'll defer to other members with 2.4 experience.

Link to comment
Share on other sites

  • 0
22 minutes ago, smirk said:

It probably does

Of course it does! I checked the documents (doh!) It's J38, the left-hand most jumper (side nearest the edge with all the power connectors) that selects for 24v through the probe port.

Link to comment
Share on other sites

  • 0

As mentioned before, need to know what probe you using - an inductive probe as recommended in the BOM (Omron probe) or a 3rd party probe such as BL touch, Euclid, Clicky, Quickdraw, etc. Do you probe when the bed is hot or cold. Do not probe whilst the bed is heating as this expands the print surface and probe values will be different, and may trigger this error. Do you probe over a magnet? (Some beds have magnets inserted, in the surface). What is the distance between the nozzle and the probe? What is the Z-Offset and tolerances for the probe - these may be too small, thus throwing errors. Sorry for the rambling but trying to troubleshoot as much as possible.

If you can, please let us know the type of probe and post your [probe] section of your printer.cfg 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...