Jump to content
  • 0

Adjust the speed of Z when doing the QGL? (in my case with Klicky)


Buurman
 Share

Question

I found where to adjust the Z speed for homing, and the second Z speed for homing (second probe) but it seems that, at least with Klicky, the QGL speed is set somewhere else, it seems to not be influenced by the default (G28) speed setting.

I feel this probing speed of QGL is just a little too fast, and I do get failures sometimes that he cant get a decent probe result.

I woudnt mind it going a bit slower... will cost maybe a few seconds on a full QQL run...  

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Answering my own stupidity, again...

But it the PROBE part in the printer.cfg that sets this.

I have set speed to 2, retract on 1 (mm) and 5 retries, seems much smoother now, it was too fast and hitting the bed too fast.

This setting may even be fast, less retries, and smaller retract, since you only need 1mm. (not the default 3.)

 

speed: 2
samples:5 
samples_result: median
sample_retract_dist: 1
samples_tolerance: 0.01
samples_tolerance_retries: 5

  • Like 1
Link to comment
Share on other sites

  • 0
15 hours ago, Buurman said:

Answering my own stupidity, again...

But it the PROBE part in the printer.cfg that sets this.

I have set speed to 2, retract on 1 (mm) and 5 retries, seems much smoother now, it was too fast and hitting the bed too fast.

This setting may even be fast, less retries, and smaller retract, since you only need 1mm. (not the default 3.)

speed: 2
samples:5 
samples_result: median
sample_retract_dist: 1
samples_tolerance: 0.01
samples_tolerance_retries: 5

My extract from pinter cfg for QGL

speed: 150
horizontal_move_z: 15
retries: 5
#retry_tolerance: 0.0075
retry_tolerance: 0.00500
max_adjust: 10

 

and for homing:

[safe_z_home]
##  XY Location of the Z Endstop Switch
##  Update -10,-10 to the XY coordinates of your endstop pin 
##  (such as 157,305) after going through Z Endstop Pin
##  Location Definition step.
home_xy_position:206,300
speed:100
z_hop:10
 

and for meshing:

[bed_mesh]
speed: 150 
horizontal_move_z: 15
mesh_min: 50, 25
mesh_max: 250, 225
fade_start: 1
fade_end: 10.0
probe_count: 5,5
mesh_pps: 2,2
algorithm: bicubic
#algorithm: lagrange
bicubic_tension: .2
relative_reference_index: 12
split_delta_z: 0.0125
move_check_distance: 3
 

Seems to work OK

Link to comment
Share on other sites

  • 0
13 minutes ago, Buurman said:

whats under your PROBE part?

 

[probe]
##  This probe is not used for Z height, only Quad Gantry Leveling
##    Euclid Probe
x_offset: 1.0                ; probe is offset 1.0mm from nozzle
y_offset: 24.0               ; probe is +22mm from nozzle in Y direction
z_offset:9.5                ; trigger point is 9.5mm below nozzle. larger numbers move effective Z0 CLOSER to the nozzle
speed: 5                     ; probing speed of 5mm/second ideal is <10mm/sec  
lift_speed: 10               ; probe lift speed
samples: 3                   ; number of probes to perform per sample
samples_result: median       ; normalization method: see config reference
sample_retract_dist: 3.0
#samples_tolerance: 0.006
#samples_tolerance_retries: 3
 

 

Link to comment
Share on other sites

  • 0
18 minutes ago, mvdveer said:

[probe]
##  This probe is not used for Z height, only Quad Gantry Leveling
##    Euclid Probe
x_offset: 1.0                ; probe is offset 1.0mm from nozzle
y_offset: 24.0               ; probe is +22mm from nozzle in Y direction
z_offset:9.5                ; trigger point is 9.5mm below nozzle. larger numbers move effective Z0 CLOSER to the nozzle
speed: 5                     ; probing speed of 5mm/second ideal is <10mm/sec  
lift_speed: 10               ; probe lift speed
samples: 3                   ; number of probes to perform per sample
samples_result: median       ; normalization method: see config reference
sample_retract_dist: 3.0
#samples_tolerance: 0.006
#samples_tolerance_retries: 3
 

Yeah, same thing, this is the one that controls the Z QGL probing speed, not the other ones.

Your retract distance can probably also be much shorter than 3, the switch is already off the bed with 1mm.

I changed speed from 5 to 2, its the same result in speed (since the retract is much smaller) but its more accurate now.

Edited by Buurman
  • Thanks 1
Link to comment
Share on other sites

  • 0
38 minutes ago, Buurman said:

he whole safe_z_home part in my config is disabled (I think its the advise klicky/auto home stuff.

I think that is if you use the probe both as an end stop and a Z-Probe. In Euclid you would use 

[homing_override]

for that purpose

 

Link to comment
Share on other sites

  • 0
24 minutes ago, mvdveer said:

QGL and bed mesh Z-speeds the same. That would be z-hop?

This line is the one that sets the Z speeds for bed_mesh and QGL 😉

[probe]

speed: 5                     ; probing speed of 5mm/second ideal is <10mm/sec  

Z_hop is only used for G28 homing.

Edited by Buurman
Link to comment
Share on other sites

  • 0
8 minutes ago, Buurman said:

[probe]

speed: 5                     ; probing speed of 5mm/second ideal is <10mm/sec  

Now you got me confused.

As per Klipper documentation on QGL: No longer confused - you are indeed correct - Thank you

#speed: 50 # The speed (in mm/s) of non-probing moves during the calibration. # The default is 50.

and for probe:

#speed: 5.0 # Speed (in mm/s) of the Z axis when probing. The default is 5mm/s.

 

No longer confused - you are indeed correct - Thank you

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...