Jump to content

Putty not connecting to my Raspberry


golddustpeak
 Share

Recommended Posts

I down loaded MainsailOS 0.61 from GitHub and flashed it to a micro SD card.

I then went into the WiFi config file with a good text editor and set up my WiFi information.

Put the card in the raspberry pi 3 and turned it on.

I then looked at my network connections with an IP scanner and found the raspberry.  When I put the IP address in Putty it gives me the Network Error Connection Refused message.

I can ping the raspberry from several computers but cannot connect via Putty.

I looked over the internet but found little help any ideas as where to go from here?

Link to comment
Share on other sites

34 minutes ago, golddustpeak said:

I believe you have to touch a file called ssh in the system-boot directory. On a UNix box, mount the sd card, cd into the root filesystem and run 'touch ssh' command. It creates an empty file.  I would recommend assigning a static IP once you get it the way you like it.

 

 

Edited by larryb
Link to comment
Share on other sites

A little more information but no joy.

Further research shows larryb above to be correct.

I created the ssh blank file and rebooted the raspberry  pi 3B.

Same IP address found, ping finds it but Putty still refuses to connect.

I removed the card and the ssh file was gone as I think it should be.

It's still a mystery.

Link to comment
Share on other sites

Poor me I'm using Win 7 and Win 10 on my machines.

The ssh file was on the root / boot directory of the card.

I'm not wanting to download a new MainsailOS 0.61 and re-flash it as that just makes no since to me, but what is left to try?

I really like answers not easteregg solutions 😞

 

Link to comment
Share on other sites

It might be easiest to reflash. Try using the Raspberry Pi Imager utility instead of Etcher. Then use the secret WiFi setup menu (Ctrl-Shift-X) and get all your settings done in there. Make sure to set your region correctly. Then there's no messing with the ssh or supplicant files, it's done as part of the flash process.

Link to comment
Share on other sites

HA! After checking my router I discovered that the raspberry I had been attempting to connect to was a wired LAN unit I had forgotten that I had.

So now I can safely say the raspberry 3B I'm attempting to connect to is NOT appearing on an IP scan.

Not only that but when I connect the raspberry Ethernet port to my router, none of the port leds light (raspberry or router).

I've re flashed a card and fixed the wpa file with the same results.

I don't sere anything in any of the other files that might cause this.

I do not have a HDMI monitor near the raspberry and I'm hesitant to take the raspberry out of the VORON and move it to a HDMI monitor.

But If that's the next step I'll move it and find a way to power it and talk to it.

As to region and country there is a note in the wpa file saying to do that for 3B + and later.

Now what?

Link to comment
Share on other sites

Awesome! I'm glad that worked. IMHO the Raspberry Pi Imager is a game changer with that hidden menu. I've flashed a few Pis with Balena, and it's always an adventure messing with the WiFi setup files. Imager makes it so much easier, I just wonder why they hide the function.

One thing that's usually mentioned is to use an editor like Notepad++ if you have  to edit wpa_supplicant. Because regular Notepad won't save to a proper Linux format and screws up linefeed. Thus making the file unreadable by the Pi.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...