Jump to content

Voron 2.4 Heater extruder not heating at expected rate. Printing stopped and Error resulted.


SteveS
 Share

Recommended Posts

I have searched my printer.cfg file and can't find sections that have the default settings. I located this code in the Config_Reference.md

The #max_error: 120 probably needs to be increased. However I can't find this in my config file. 

Does anyone have any suggestions.

 

[verify_heater heater_config_name]
#max_error: 120
#   The maximum "cumulative temperature error" before raising an
#   error. Smaller values result in stricter checking and larger
#   values allow for more time before an error is reported.
#   Specifically, the temperature is inspected once a second and if it
#   is close to the target temperature then an internal "error
#   counter" is reset; otherwise, if the temperature is below the
#   target range then the counter is increased by the amount the
#   reported temperature differs from that range. Should the counter
#   exceed this "max_error" then an error is raised. The default is
#   120.
#check_gain_time:
#   This controls heater verification during initial heating. Smaller
#   values result in stricter checking and larger values allow for
#   more time before an error is reported. Specifically, during
#   initial heating, as long as the heater increases in temperature
#   within this time frame (specified in seconds) then the internal
#   "error counter" is reset. The default is 20 seconds for extruders
#   and 60 seconds for heater_bed.
#hysteresis: 5
#   The maximum temperature difference (in Celsius) to a target
#   temperature that is considered in range of the target. This
#   controls the max_error range check. It is rare to customize this
#   value. The default is 5.
#heating_gain: 2
#   The minimum temperature (in Celsius) that the heater must increase
#   by during the check_gain_time check. It is rare to customize this
#   value. The default is 2.

 

Link to comment
Share on other sites

You can simply add the section to your printer.cfg, fill in your heater name for heater_config_name and uncomment max_error. something like:

[verify_heater extruder]
max_error: 999 #120
 

Probably a good idea to do heater calibration afterwards and make sure everything works as expected.

 

  • Like 1
Link to comment
Share on other sites

Great thanks for the info. This is my first Voron 2.4 build and the mechanics and electronics I'm ok with having background in Product Design Engineering however the coding

is something new to me. So if you don't mind I might ask you some simple questions.

1. What I don't understand is how can you get an error if the code isn't in the printer.cfg ?

2. I entered the following lines into my printer.cfg (see attached) at the end of the extruder section.

[verify_heater extruder]

max_error:  140

I still had the same printing fail. Should I increase it more?

3. Does it matter were the code is inserted  i.e. Does it need to go in the  Extruder section ?

4. When I select print I keep getting Unknown command:486 ??  (see attached) and multiple messages all while printing?

 

Thanks again for your assistance.

Cheers

 

verify-heater.jpg

printing stopped.jpg

Link to comment
Share on other sites

I had something similar when I installed a Mosquito thermistor + 450 degree capable heater in my v0. I enlarged the max error enough to allow me to do a heater PID calibration, after that I could lower it again. All this assumes that you configured the right thermistor type in the extruder heater section. In the screenshot I can see you entered "ATC Semitec 104GT-2", are you sure that is your thermistor type? Usually kits have just a "Generic 3950". *if* you have the wrong thermistor configured then no amount of max error increase will help. I believe you can check your thermistor type with an Ohm meter, but you'll have to look that up.

Link to comment
Share on other sites

ps Do a PID calibration, in my case I had to temporarily increase the Max Error to be able to de the PID calibration. My guess is the previous values were just too far off. BTW M486 has something to do with object labelling in super slicer iirc.

Link to comment
Share on other sites

 

 

This is the 'verify_heater' for my printer chamber, I described in details how it works. put all elements in your extruder heater config and adapt your numbers.

[verify_heater CHAMBER_HEATER]

max_error: 20000          # (in degC*sec : error score) every second, if temp is beyond 'hysterisis' below, the counter will add up the temperature error to the error score untill the 'max_error' is reached , resets when temp is inside 'hysterisis'

check_gain_time: 300    # (in seconds) while initial heating, will make sure that every time 'check_gain_time' delay has passed, temperature has went up by 'heating_gain' below

hysteresis: 5           # (in degrees c)

heating_gain: 1       # (in degrees c)

 

 

 

Link to comment
Share on other sites

I think it's your heater tube, but more likely the wires. If the thermistor reads about room temp. Then it heater.

Put your meter probes on either side of heater wires at the board, there should be continuity through the heater.

Some heater wires are too stiff and break really quick. Better to run new wires,than replace tube.

Link to comment
Share on other sites

Hi again. I have been doing more tests today and found that after about 5 minutes the Extruder heater goes to 100% but the heating starts dropping. See image.

I tested the Extruder by running it for an extended period of time and all OK stayed at target temp.

The multiple error messages:unkown command M486 is a concern. This comes up immediatly I press print. Is it possible the part file is corrupted? I used Superslicer for G-code export.

If you have any other suggestions to try, I would appreciate the help.

Cheers Steve

 

IMG-8530.jpg

Link to comment
Share on other sites

Given your last screenshot it seems to me that your thermistor *is* working but there is something wrong with your heater, most likely a bad or broken wire somewhere. I would, as a test, temporarily run a new wire from your controller board to the heater (don't bother routing it through the chains) and test. If that fails I would get a new heater cartridge.

Link to comment
Share on other sites

  • 2 months later...
  • 4 months later...

Hello good people!

I have a somewhat similar problem... I can not (or the printer can not) control the temperature of the hot-end. The temperature jumps very high no matter what value I put in. For ex.: I set to 50 it goes up to 100 in like 5-6 seconds. The PSU is 24V also the heater tube, or so it was sold to me. I've tried several thermistors in the printer.cfg file, generic 3950 included. I can not do a PID calibration because it goes above the targeted 245 degrees and of course it shuts down. I have also put a new thermistor and a new heater tube and same dance happening... The thermistor I use is 100K, small glass bead type like the one attached. I'm using these type for many years and they are working just fine.

Can anyone give me an idea or what else should I try? Thank you in advance!

tesseract-100k-ohm-ntc-3950-thermistor-temperature-sensor-for-3d-printer-extruder-1000x1000.webp

Link to comment
Share on other sites

If you're seeing rapidly fast increases in termperature I would suspect it is false reading rather than you've somehow got 2KW heater for your hotend 🤔 To be honest even if you had the wrong thermistor definition in printer.cfg I still would not expect it to change incredibly rapidly. I would just expect to see the wrong temperatures, changing slowly as you might normally expect rather than the hugely rapid changes you are seeing.

I am not entirely clear if you have tried physically different thermistors (I believe you have just tried different definitions in the printer.cfg). The easiest thing (see below) is probably to try a different physical thermistor (ideally a know good one).

I would suspect either the physical thermistor or the port on the control board itself.

What I would suggest you do (if you have one) is use a multimeter to measure the resistance of the thermistor. The resistance will vary with temperature. Simply holding the thermistor in your hand (versus room temperature) you should see a decrese in resistance. If you are confident the thermistor is a generic 100K type of thermistor you can easily look up a resistance table on the web. For example:

resistance-100k.thumb.png.7314a84976dfdce44a882a68f9643339.png

Before you try turning on heaters do the temperatures on both thermistors (hotend and bed) look comparable (around room temperature)? They might not be exactly the same (but I'd expect them to be within 1 or 2C if they are the same type of thermistor) and as long as things are cold I would expect them also to be around ambient temperature. If the hotend is way out that points to an issue.

The other thing I might try is swapping the connections on the printer control board. If you have another thermistor port (say intended for a second hotend) the would be a good start (naturally you will need to change the pin definition in the printer.cfg file). If things magically start working as expected then it would point to a faulty thermistor port on the control board. If the issue follows the swap of ports it either indicates a faulty thermistor (or the incorrect definition in printer.cfg). At a pinch (if you've only got 2 thermistor ports) you could try swapping the hotend and heated bed definitions but that's a bit more messy.

 

Link to comment
Share on other sites

Thank you very much for both answers! I really appreciate it! As soon as I'll be home I will try the swamping! The cables can not be because when I've tried the new NTC and heater tube, I've just inserted them directly on the SKR board (mini E3 v.2) using of course their cables. One question pops in my mind: what if instead of 24V heater cartridge they sold me 12V ones? Could this cause this issue, this sudden and uncontrol-able jump in temp?

Link to comment
Share on other sites

it probably would not be good to drive a 12v heater at 24v for any length of time (you'd probably burn it out) but it wouldn't magically generate more power to heat up the mass of the hot end heater block any faster than a genuine 24v.

Link to comment
Share on other sites

Yes, of course isn't right but could this be the cause of my problem?

So, right now I've just swapped the plugs from the heat-bed and hot-end. Started up the printer and introduced 50 in the "bed" section and the temp has only stop at 80 degrees... soo... it's not he NTC port, not the cables... but what? Measured one of the NTC has 85 and the other one 114 Kohms at at room temperature ...

Link to comment
Share on other sites

41 minutes ago, eugen360 said:

Measured one of the NTC has 85 and the other one 114 Kohms at at room temperature ...

I might be misreading but one thermistor (using the multimeter) is reading  85 kOhms and the other is at 114 kOhms at the same ambient temperature (basicly "room temperature")? Looking at the (granted arbitrarily selected resistance table) that means one things it's about 28C and the other thinks it is around 21-22C 😳? That's a bit of a variance, depending on your actual room temperature one of those thermistors is goosed. (Unless of course they're different models so really different resistance tables apply). There is also the small chance the actual thermistor is "labelled" incorrectly and it's not really a generic NTC100k unit but something else?

Link to comment
Share on other sites

56 minutes ago, eugen360 said:

Yes, of course isn't right but could this be the cause of my problem?

Sorry, missed the first question,I would say "No", the worst I'd expect is the heater to burn out (perhaps damaging cables and the port). i would not expect it to be super-charged and cause radical increases in temperature (and if the thermistor is working) I certainly would not expect it to exceed maximum temperature. Interesting some safey feature has not cut in but I guess they are aimed at the temperature not rising fast enough (on the basis the heater has fallen out or failed).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...