Jump to content

help with installing input shaper

Recommended Posts


Greetings. I’m trying to incorporate input shaper on my Trident with SB2040 and Octopus 1.1
I followed the instructions on the Mellow wiki, installed the accelerometer packages (which only took a minute ?) enabled SPI on the RPI, did the menuconfig to add the RPI as Linux Process, added the RPI as mcu in the printer.cfg so it looked like this

[mcu rpi]

serial: /tmp/klipper_host_mcu


added the ADXL345 :


cs_pin: sb2040:gpio1

spi_software_sclk_pin: sb2040:gpio0

spi_software_mosi_pin: sb2040:gpio3

spi_software_miso_pin: sb2040:gpio2


accel_chip: adxl345


    175, 175, 20 


Restarted everything and I got a Protocol error:

MCU Protocol error
This is frequently caused by running an older version of the
firmware on the MCU(s). Fix by recompiling and flashing the
Your Klipper version is: v0.12.0-180-g79930ed9-dirty
MCU(s) which should be updated:
mcu: Current version v0.11.0-205-g5f0d252b
sb2040: Current version v0.11.0-275-g8ef0f7d7-dirty-20231021_140621-Fluidd
rpi: Current version v0.12.0-180-g79930ed9-dirty-20240513_122727-Fluidd
Up-to-date MCU(s):

Once the underlying issue is corrected, use the "RESTART"
command to reload the config and restart the host software.
mcu 'sb2040': Command format mismatch: query_adxl345 oid=%c rest_ticks=%u vs query_adxl345 oid=%c clock=%u rest_ticks=%u

I have updated all packages as far as I know.

I then disabled the ADXL entries and everything was fine again.

I don’t know where it went wrong. I’ll include my Klippy.log and hope somebody can help.






Link to comment
Share on other sites

Posted (edited)

I have a mellow fly 2 in my 'backup tools' cupboard. Never installed it and probably never will...

But if I have learned one thing from things on this forum, that is never read or trust the mellow documentation. They are written in Chinese and then translated through Tao Bao Translator.

But... without having experience with this board, but having experience with klipper, this message tells you that one of your flashed boards, probably the one with the ADXL, the mellow fly 2, is not up to date.

this message: 


mcu 'sb2040': Command format mismatch: query_adxl345 oid=%c rest_ticks=%u vs query_adxl345 oid=%c clock=%u rest_ticks=%u

Says it is trying to talk in a way that is not expected. Probably due to a mismatch between the flashed firmwares.

It can also be klipper itself.

I know that you have written that they are all up to date, but I would check again.


ps: searching for the above error on duckduckgo.com gives this site: https://github.com/bigtreetech/CB1/issues/160

where people are advised to re-run the make for the linux proces.

I remember several people having the same problem a while back 🙂


Edited by Dirk
Link to comment
Share on other sites

Thanks for your answer. I tried updating my toolhead mcu by stopped the Klipper service, menuconfig and make, moved and renamed the file , and tried flashing with 

python3 flash_can.py -i can0 -u 55bd44de9494 -f ~/firmware/sb2040_1.0_klipper.bin

result :

python3: can't open file '/home/pi/flash_can.py': [Errno 2] No such file or directory

I've been at it for two days straight but I don't understand why Liux has to be so obscure.

Link to comment
Share on other sites

11 hours ago, mbunjes said:

don’t know where it went wrong. I’ll include my Klippy.log and hope somebody can help.

You need to update the Raspi pi:

SSH into your Raspi then issue the following command:

sudo systemctl stop klipper

This will stop the klipper service on the Raspi.

Issue the following commands:

cd ~/klipper
make clean
make menuconfig


Choose "Micro-controller Architecture (Linux Process)

Press Q and test to save.

Issue the following commands:

make flash
sudo systemctl daemon-reload
sudo systemctl restart klipper

All should be working now.

  • Like 1
Link to comment
Share on other sites

Well, I followed every step meticulously but when I fire up the printer it doesn't initialize and I get the error message : mcu 'sb2040': Unable to connect.

Is it an idea to reinstall canboot and Klipper on the SB2040 ? Should I install and configure Katapult or is it just another part that could go wrong ?

Is there an easy, step by step, foolproof way to update Klipper on the Octopus (I always first have to adjust the mcu_timing before updating) and the SB2040 ?


Link to comment
Share on other sites

I'm trying to reinstall everything following Esoterical's website but after flashing Katapult to the main board I can't get a response to "ls /dev/serial/by-id"

The board (Octopus v1.1) seems to be going in DFU mode (blinking red light) when I double click the reset button but the above command only returns "no such file or directory"

I've tried several times and I'm absolutely sure the config is correct so what else can I do ?


Link to comment
Share on other sites

As I have mentioned, not an expert in the mellow stuff... but I have seen many people succeed following Esotericals guide.

The error you get sometimes is an OS problem. So make sure you have the latest Pi Os installed.

And Esotericals site also has troubleshooting sections where you can find answers to those questions.

Another nice guide dealing with your exact setup can be found here: https://github.com/cruiten/Voron-Related/tree/main/CANbus/Documentation

And if you are still not set up, I am sure @mvdveer will give you some more directions. He has the sb2040 installed on 10 printers 🙂

Link to comment
Share on other sites

Just a quick side note here. If you get really frustrated and things don't work out - here's what I did and it worked out great for me.

I have a 2.4r2 that I had for over a year and was always afraid to start down the input shaper path because it seemed really complicated. I bought a Pi Pico and the ADXL module, and printed stuff for it but never dove in. This a YT video showed up that talked about a new option, which is the Fysetc "PIS" module, and I got one from Aliexpress. After about a week or so it arrived, and it was not bad at all to install and use.


The instructions I followed to generate the Klipper firmware for the pico were all covered well in the linked YT video on that page:


Anyway, keep it as a backup option and once you've set it up you can use it on more than one printer by just moving it over and adding the config file to the new printer.



Link to comment
Share on other sites

I have this same issue on the last Klipper update. All you need to do to resolve the issue is update all of you MCUs to the same level of Klipper.  I am running SB2209 on several printers but should be the same on a 2040. I did not have can boot installed so took the time to put Katapult and it is very easy to update the can bus toolhead now. The link above to Esoterical's guide is the way to go to get it all done and working... Good luck!

Link to comment
Share on other sites

Sadly it went from just wanting to use input shaper on a perfectly working Trident to all software failure. After updating I could not get a serial id no matter what I tried and the Esoterical site catgorically states that if you can't get a serial id you might as well forget it.The printer stopped responding after start up so after 4 days of growing despair I decided to reeinstall everything. I don't know however if this will work after installing the Katapult bootloader. We'll see.

Maybe Dennis's suggestion is worth looking into, it seems a lot simpler.

Link to comment
Share on other sites

I ran into this also when updating everything, turned out to be that I used to wrong settings while updating one of the MCUs. after re-compiling the firmware correctly everything started working again. I have also made the Pico pi external input shaper USB devices and it works as well but I do like not having to fuss with plugging into the USB port on my printers to run input shaper.

  • Like 1
Link to comment
Share on other sites

24 minutes ago, Jeffware said:

I used to wrong settings

Most likely the cause of the issue described. Been there done that!

Link to comment
Share on other sites

Posted (edited)
1 hour ago, mbunjes said:


Never dispair.

Follow Esotericals guide. And if it doesn't work out, join the voron discord the can and usb toolhead channel. There are plenty of people who will be glad to help you through this.

Esoterical is a very kind and patient guy from Australia. Like @mvdveer... If you join on the day time for them, he will even help you.

Edited by Dirk
Link to comment
Share on other sites

OK, I really took my time, followed Esotericals guide and I am extremely happy to say my Trident is back up.

With the sinking realisation that I don't have back-ups of my printer.cfg. macro's etc. so I'm starting from scratch again.

Lesson learned.


  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...