Jump to content
  • 0

Probe Calibration


TitusADuxass

Question

V0.1, BTT M5P, EBB36, Microprobe 

I need your assistance once again.

I'm trying to calibrate the Z offset and have the following issues:

X, Y & Z all home correctly and Z is in the centre of the bed (60, 60).

When I issue command PROBE_CALIBRATE, the toolhead motors over toX0, Y23.

Then when I try to raise the bed by 1mm (it'sat 5.01), it goes up by 1mm and then back down.

Where do I find the area that I need to change?

TIA

Edited by TitusADuxass
Clarification
Link to comment
Share on other sites

21 answers to this question

Recommended Posts

  • 0
21 minutes ago, TitusADuxass said:

Where do I find the area that I need to change?

Have you got a section [safe_z_home] defined?

[safe_z_home]
##  XY Location of the Z Endstop Switch
home_xy_position:60,60
speed:100
z_hop:15
Quote

 

Customized homing

[safe_z_home]

Safe Z homing. One may use this mechanism to home the Z axis at a specific X, Y coordinate. This is useful if the toolhead, for example has to move to the center of the bed before Z can be homed.

 

 

Link to comment
Share on other sites

  • 0
18 minutes ago, TitusADuxass said:

I suspect that it's something in the microprobe.cfg

That may be it, but just had a look at some sample configs for the Bique Microprobe and it does not reference X-Y - positions

 

Link to comment
Share on other sites

  • 0
19 minutes ago, TitusADuxass said:

I changed the X Y offsets in the microprobe.cfg to 60, 60.

That will cause a move out of range. These are the values the probe is from the nozzle, won't be 60,60

e.g.

x_offset: 0.0 # Actual offset of the MicroProbe installation - how far is the probe from the nozzle on the X-axis - in line
y_offset: -31.5 # Actual offset of the MicroProbe installation - how far is the probe from the nozzle on the Y-axis -31.5mm from nozzle 
#z_offset: 0.0 # Actual offset of the MicroProbe installation

or

x_offset: -40  
y_offset: -35 

 

Link to comment
Share on other sites

  • 0
10 minutes ago, mvdveer said:

That may be it, but just had a look at some sample configs for the Bique Microprobe and it does not reference X-Y - positions

It does require you to input an offset for Z, I've commented out the X & Y lines.

It now runs as it should during the probe calibration but I can't get the nozzle down to the bed. The lowest that I can go is (according to Get_Position) 0,0025, but measured with a feeler guage it's 0.04 above the bed.

Link to comment
Share on other sites

  • 0

@mvdveer

Username changed because I'm using my laptop.

If I have this in the microprobe.cfg

[probe]
pin: ^!EBBCan: PB8  # NOTE FOR V2 users: Set this to ^!PC14 to set the low level trigger 
deactivate_on_each_sample: False
x_offset: 55 #60
y_offset: 37 #60
z_offset: 0.0 # Will be overridden when you do a PROBE_CALIBRATE

I get this error - Move out of range: 115.000 97.000 5.051 [0.000]

If I change the x & y offsets to -55 and -37 it moves the toolhead to x5 x23

If they are both at 60 the toolhead stays where it is (60,60)

I think I have nailed the Z height adjustment, I forgot all about the bedscrews!! This is my first printer where the bed moves up and down.

 

Link to comment
Share on other sites

  • 0

Taking a quick look at the Klipper documentation for the [probe] section, it shows this:

Quote

#x_offset: 0.0 # The distance (in mm) between the probe and the nozzle along the # x-axis. The default is 0.

#y_offset: 0.0 # The distance (in mm) between the probe and the nozzle along the # y-axis. The default is 0.

Looking in my Trident (with Tap) my x_offset and y_offset are both at 0--which makes sense since now the nozzle is the probe. I have my old settings from Klicky (and probably inductive) commented out, and it had y at 25, which makes sense since that was behind the nozzle. So how far away is your sensor from your nozzle tip?

If you do the math on your settings, it makes sense. Starting at 60,60 and moving -55, -37 gets you to 5, 23. 

So that's x and y. For z, my Trident has position_min under stepper_z bumped to -6.5 from default of -2.5. That's allowing you to move the nozzle down from theoretical 0 to get to the physical bed during calibration. So, like @mvdveer said, try inputting -5 for now and bump it up if that's not enough.

Link to comment
Share on other sites

  • 0
Posted (edited)
1 hour ago, claudermilk said:

Taking a quick look at the Klipper documentation for the [probe] section, it shows this:

Looking in my Trident (with Tap) my x_offset and y_offset are both at 0--which makes sense since now the nozzle is the probe. I have my old settings from Klicky (and probably inductive) commented out, and it had y at 25, which makes sense since that was behind the nozzle. So how far away is your sensor from your nozzle tip?

If you do the math on your settings, it makes sense. Starting at 60,60 and moving -55, -37 gets you to 5, 23. 

So that's x and y. For z, my Trident has position_min under stepper_z bumped to -6.5 from default of -2.5. That's allowing you to move the nozzle down from theoretical 0 to get to the physical bed during calibration. So, like @mvdveer said, try inputting -5 for now and bump it up if that's not enough.

My probe is about x +37 z -25 from the probe.

I looked at the klipper docs, I haven't yet grasped it. It moves to where I expect the offsets say it should. But it wouldn't go the other way.

Is the objective to get the probe to calibrate on the 60,60 mark?

I'll try again tomorrow, and I'll set the position_min to -5 as suggested by @mvdveer

On a plus side, I got the microprobe configured and working - so that's a positive start.

The moving bed sometimes frazzles my brain, I've gotten so used to my v2.

Edited by TitusADuxass
Additional info
Link to comment
Share on other sites

  • 0
6 hours ago, TitusADuxass said:

Is the objective to get the probe to calibrate on the 60,60 mark?

Yes and no - It is a good safe position to calibrate - the centre of the bed. The X and Y offset is important for getting an accurate 0,0 position (Front left corner of the printer normally), so that when you slice a print, it does not fall outside the boundaries of the print plate. To set these, maybe this sketch will help:

image.thumb.png.9017b9a33c801a3ceb8c1968036d4595.png

This thread here explains it better than I could and works perfectly. (Replace Octorprint with Mainsail/Fluid in the description)

image.thumb.png.6c161053b509ec007245239f91ad5ed4.png 

  • Like 1
Link to comment
Share on other sites

  • 0
10 hours ago, mvdveer said:

Yes and no - It is a good safe position to calibrate - the centre of the bed. The X and Y offset is important for getting an accurate 0,0 position (Front left corner of the printer normally), so that when you slice a print, it does not fall outside the boundaries of the print plate. To set these, maybe this sketch will help:

image.thumb.png.9017b9a33c801a3ceb8c1968036d4595.png

This thread here explains it better than I could and works perfectly. (Replace Octorprint with Mainsail/Fluid in the description)

image.thumb.png.6c161053b509ec007245239f91ad5ed4.png 

Thanks,  I've put both issues to bed now.

Now, I'm looking bed screw adjust.

  • Like 1
Link to comment
Share on other sites

  • 0
Posted (edited)

That's the extruder calibrated.

Now the Z height and the bed levelling.

I still haven't got to grips with the height of the Z end stop screw in relation to the height of the bed.

I don't know how to decide between raising the bed or changing the height of the end stop screw.

I've started with the bed springs about 50% compressed (the bed is about 15mm above the chassis/frame.

But can never get the probe low enough before I get

position_endstop in section 'stepper_z' must be between position_min and position_max

r.

Have you got any tips for this?

Edited by TitusADuxass
  • Like 1
Link to comment
Share on other sites

  • 0
1 hour ago, TitusADuxass said:

Have you got any tips for this?

FWIW... I do not have a Z endstop on my VzBot. I am using a virtual endstop and my Beacon probe. As for bed leveling... I designed some nice big bed leveling wheels and moved the head to all 4 corners and used the paper under the nozzle method. I'm currently within ~0.05mm on all corners.

I've been wanting to design a little button with an LED and coin cel battery that I can move around the bed to get it dialed in a bit closer. Not that it needs to be but, I like sh!t like this and I'm bored. 😆

Here's 3 bed leveling wheels that use M3 inserts. I'm using V3 on mine.

Knob_M3-Insert v1.stlKnob_M3-Insert v3.stlKnob_M3-Insert v5.stl

  • Thanks 1
Link to comment
Share on other sites

  • 0
2 hours ago, TitusADuxass said:

Have you got any tips for this?

This is an error message from klipper and it says exactly what it means. So you need to look at the min an max values.

You probably set position endstop to 0 and z_min to -3. Or similar.

If you post that section (or the whole ) of your printer.cfg, we can tell you probably.

Link to comment
Share on other sites

  • 0
Posted (edited)
1 hour ago, Penatr8tor said:

As for bed leveling...

Oh. Oh... I have seen some super cool vzbot mods that convert the bed to a tiltable bed, getting rid of all those ugly knobs: trident style:-)

But I must admit, putting lights in a knob also sounds cool.

Oops... Sorry .. this wasn't the vzbot. The v0. For that @mvdveer made a vzero with a twist story...

 

Edited by Dirk
Link to comment
Share on other sites

  • 0
6 hours ago, TitusADuxass said:

Have you got any tips for this?

Change your z-min to something like -15 in the printer.cfg file

Link to comment
Share on other sites

  • 0

It is defined as

position_min: -5. # -10 or -15

under the [stepper_z] section. Your's may be set to 0, if so then give it a negative value. I started at -15 and ended with -5. Just tells the machine how far it can move beyond the perceived 0 point. (Bed relative to the nozzle)

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...