Jump to content
  • 0

What causes the stepper motor to "bind/freeze/lock" on powering on?



I ran into an interesting problem whilst upgrading and maintaining a Trident 250mm build. (Build 10 January 2023 - VT.941)

Printer Configuration:

  • Raspi Pi 4B+
  • Octopus STM32446 v1.1 printer controller board with TMC2209 steppers
  • Mellow Fly SB2040 Canbus toolhead board
  • Revo Voron Hotend
  • Moons Stepper Motors 1.8 degrees

After doing all the maintenance and upgrades, the printer did not want to home. On homing either X or Y - the gantry moves in a diagonal manner. (It's not a crab - should not do this!)

On closer inspection and investigation, the A-Stepper (X- stepper, Left Hand Motor) "binds, freezes, locks" as soon as power is supplied to the printer. Even when the motors are disabled, the stepper does not move. Can move the gantry in the Y-axis, with the X-axis moving diagonally.  But cannot move in the X-Axis at all!  It is stuck, even trying to move it with force.  And.... klipper does not complain. With the power off - movement in both X and Y is normal.

Upgrades and Maintenance as background:

  • Had the original Version1 printed TAP  replaced - changed to Cartographer probe.
  • Fitted a CNC X-Carriage mount, rather than printed mount.
  • Build and mounted a Galileao extruder to replace the CW2 from the Jan 23 build.
  • Changed the Ramalama front Idlers to Beefy front Idlers.
  • Added Titanium Gantry Stabilisers.
  • Tightened all the screws.
  • Installed Cartographer software. (Seperate cartographer.cfg file and [include cartographer.cfg] in printer.cfg)

Troubleshooting so far:

  • Changed the motor cable from the printer board to the stepper motor - motor still locked/bound
  • Connected another motor to the existing cable - motor still locked/bound
  • Connected new motor with new cable - motor still locked/bound
  • Replaced stepper driver on Motor0 port on octopus - motor still locked/bound
  • Moved motor connection from Motor0 to Motor5 port on Octopus - motor still locked/bound
  • Removed motor from the printer (A-Drive / X) and tested outside of printer (on a test board) - rotates/moves  freely - not locked/bound
  • Disabled newly installed cartographer software - motor still locked/bound

Conclusion from troubleshooting:

  • The original motor is not faulty
  • The original cable to the motor is not faulty
  • The stepper driver is not faulty
  • The motor port is not faulty

Is it software or hardware ?

If it is hardware, it would need to be the octopus board, but changing motor ports on the board, did not solve the problem. 

If it is software, Klipper should complain - it does not.

Now my question - what the heck is going on?


Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0
48 minutes ago, PFarm said:

Weird issue! What about using a previously saved printer.cfg to rule out software?

Going to do that tonight. Was actually thinking of starting from scratch. Reformatting the Raspi Pi card and re-installing Klipper and the likes.

  • Like 1
Link to comment
Share on other sites

  • 0
8 hours ago, PFarm said:

What about using a previously saved printer.cfg to rule out software?

Spot on- restored a config form Jan 24 - the last backup file - problem solved - now I need to compare and see what caused the issue! Thanks mate! 

  • Like 1
Link to comment
Share on other sites

  • 0

Found the problem - how it happened I do not know, but somehow I changed the [stepper_x] enable pin


enable_pin: !PF14

the non-working printer cfg

enable_pin: PF14


  • Like 2
Link to comment
Share on other sites

  • 0
4 minutes ago, Dirk said:

So your binding was a disabled motor.

Good to think of next time you encounter something like this.

No, actually an enabled motor, that why it appeared locked/frozen/stuck. In retrospect it all sounds so logical. But in the moment , with blinkers on- you cannot see the obvious.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...