Jump to content

Voron 0.1 BTT M5P / CB1 ethernet only

Recommended Posts

I have a V0,1 which I intend to use in my camper (I can't go for a whole month without printing or tinkering).

Most campsites have crepe wifi and I'd need to change the system.cfg at each campsite which would be a right royal PITA. So the plan is to connect to the printer via an ethernet cable.

I've tried simply connecting the cable but the printer always connects via my home WiFi,  if I switch the WiFi off the printer gets an arse on.

How can I force it to use ethernet? 

Link to comment
Share on other sites

I tried the first suggestion cron job @reboot ifconfig wlan0 down - no joy

So I added sleep to the cron job - still no joy

Directly sending ifconfig wlan0 down did nothing to the WiFi, but sudo ifconfig wlan0 down works.

My tip - don't put it in your cron job or you'll not be able to ssh into it - ask me how I know...

It looks like eth0 is not activated during a normal boot up.

Link to comment
Share on other sites

Their seventh option might fit your scenario better. If you run systemctl | grep wpa then it should show that the service is running. You can then use sudo systemctl disable wpa_supplicant and reboot for it to take effect. After your trip you can use sudo systemctl enable wpa_supplicant and reboot to allow the pi to connect to your WiFi again.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...