Jump to content

BTT EBB SB2209 Troubleshooting some issues (DFU, Neopixel, Thermistor)

Recommended Posts

After a frustrating weekend of debugging multiple issues with an SB2209 (STM32 version) in my newly finished V2.4, I wanted to provide a summary of the solutions to a few problems because I couldn't find concise answers to most of them, even though they seem to be questions asked quite frequently.


Problem 1: My SB2209 refused to enter DFU mode. I made sure to have the 5V jumper installed, no CAN cable connected, USB-A to USB-C cable confirmed to have data connections and plugged into the pi (and later my computer with no better luck). I would press and hold the Boot button while quickly pressing Reset and then releasing Boot, just like all the instruction manuals said (both BTT manual and Esoterical's guide linked here: https://github.com/Esoterical/voron_canbus). No DFU device showing on the Pi after running the following command:

sudo dfu-util -l


Proceed to retry this ~50 times with increasing frustration. Search all forums known to man and try every solution listed. No Luck. I asked for help in Discord and was told the board is probably bad, so I opened a ticket with West3D to get a replacement. Then I had an idea. a few manuals showed the board being flashed before being installed. I unplugged EVERYTHING, even the fan board and tried again. SUCCESS! Further flashing steps went without note. Not my first Can setup, made sure to follow the guide exactly as written.

TLDR: Make sure you try it with 5V jumper installed, USB cable 100% has data lines, no can cable connected, EVERYTHING unplugged. If that doesn't work, you might have a dead board. 


Problem 2: Thermistor error (MCU shutdown: adc out of range). I thought this was either a dead pin or a config problem. Tried the PT1000 from my Rapido connected to the MAX chip and the TH0 port, both with no luck. Triple checked wiring on the board and pin assignments without finding any errors. It finally dawned on me that my error said 'mcu,' not 'mcuEBB.' Flipped the printer over and saw my bed thermistor plugged into TH1, but I had the config looking at TH0. swapped config pins and was good to go. TH0 now has an old PT100 attached and is working perfectly since adding pullup_resistor: 2200 as needed for Leviathan Board


Problem 3: My Stealthburner Rainbow Barf Neopixels wouldn't light up. I made sure to follow this guide: https://github.com/tanaes/whopping_Voron_mods/tree/main/LEDs/Rainbow_Barf_Logo_LED to the letter. My harness was pre-made from KB3D, so I could skip the soldering section, though I did double check later just to be sure. Downloaded the Klipper LED Effects plugin, added the config file and changed pin assignment to EBB LED pin. Nothing! I looked around for the solution and tried the PWM fan data line with no luck before moving the neopixel data line to the 3rd pin of the BLTouch port. Change pin assignment in klipper and we have lights!


I plan to make a quick YouTube video going over all of these issues and will link that below once it is ready.


Edited by MrSprinklz
  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...