Jump to content

Webcam Help?


Recommended Posts

My webcam won't start on printer startup, or after reboot.  I get the following error in the crowsnest log:

[03/25/23 06:50:24] crowsnest: INFO: No usable CSI Devices found.
[03/25/23 06:50:25] crowsnest: V4L2 Control: No parameters set for [cam Voron]. Skipped.
[03/25/23 06:50:26] crowsnest: Try to start configured Cams / Services...
[03/25/23 06:50:26] crowsnest: INFO: Configuration of Section [cam Voron] looks good. Continue...
[03/25/23 06:50:27] crowsnest: Starting ustreamer with Device /dev/video0 ...
[03/25/23 06:50:28] crowsnest: ERROR: Start of ustreamer [cam Voron] failed!
[03/25/23 06:50:28] crowsnest: ... Done!


But, if I run the following command from the Crowsnest github, the cam will start working.  It works fine, with no problems until the next time I shut down the printer.  Then, after starting the printer again, no webcam unless I run this command again:



Any Idea how I can permanently fix this, without having to SSH into the Pi and rerun the script every time I want to use the printer?


If it's any help, the closest thing I can find to an error when running that buildclean command, is this "warning: -j4 forced in makefile: resetting jobserver mode." :






Edited by ken226
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...